PHP, which is a backronym for PHP: Hypertext Preprocessor, is among the most famous open-source web programming languages available out there. Any site or web-based application built with PHP will run on a given web server on the condition that a PHP module is installed, which renders the language really universal and it isn’t that surprising that there are actually a few million web servers that support it and hundreds of millions of PHP sites running on them. PHP is preferred over HTML thanks to the fact that it allows you to set up a responsive website with plenty of different options. A PHP-based community website, for instance, will serve different content to each user even though the URL will not change. By contrast, HTML websites are static and the page content can be modified only manually. Just like any other piece of software, PHP has several versions and the version that was used whilst setting up a given website must be set up on the server in order for the site to work flawlessly.

PHP 4 and PHP 5 Support in Shared Web Hosting

With our shared web hosting, you will be able to pick which PHP version will be enabled for your shared web hosting account, as we support multiple versions. With as little as one click, you will be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and each time a new version is released in the future, we will add it to the Hepsia hosting Control Panel without removing the earlier ones. Thus, you’ll be able to host all the sites that you’ve developed throughout the years. Unlike lots of other hosting providers, we will not compel you to update such sites, because a script may be outdated, but this doesn’t mean that it’s vulnerable since you may have performed modifications to its source code to prevent security loopholes. For your convenience, you’ll even be able to choose a different version of PHP for each site hosted in your hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

If you have a website created in an older version of PHP and you have contributed time and energy towards setting it up, patching security gaps and appending content, you will need a hosting service that can support it, as the vast majority of web hosting suppliers nowadays offer support only for the most recently published version of PHP and give up the previous ones. We, on the other hand, have decided to let you choose the version that your websites need. Our semi-dedicated servers support PHP 4 and multiple versions of PHP 5, which goes to say that you’ll be able to use both older and newer scripts without forfeiting any manual modifications or frittering away time and energy trying to make your sites compatible with the hosting environment. The current version can be changed via the Hepsia Control Panel and such a change will apply to the whole semi-dedicated server account, but you’ll also have the ability to pick a different PHP version for each single site hosted in your account by means of an .htaccess configuration file.